wordpress技巧:解决WordPress安装/升级插件时提示输入FTP用户名和密码问题

前言

我们经常在使用Wordpress程序架构的网站如果需要在网站后台升级、安装主题或者插件的时候,有时候会出现提示需要我们提供FTP信息的界面。有这样的字样提示"要执行请求的操作,WordPress需要访问您网页服务器的权限。请输入您的FTP登陆凭据以继续。如果您忘记了您的登陆凭据(如用户名、密码),请联系您的网站托管商"。这个是比较麻烦的,现在我们就把两种解决办法分享一下,大家如果有更好的办法也可以分享出来。

教程

方法一

在“wp-config.php”最后面添加以下代码解决问题:

define("FS_METHOD","direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

PS:同时解决安装插件提示“无法定位wp-content目录”问题,为了更加安全建议升级完成删除以上代码.

方法二

此方法适用于一些 LNMP 一键包所出现的错误,以我为例,如果我的网站在 /home/wwwroot/mcheng.cn 目录下,则登录 Putty 输入以下代码:

登录SSH输入以下命令:

chown -R www /home/wwwroot/mcheng.cn(修改成网站域名目录)

其中/home/wwwroot/mcheng.cn是你的WordPress的安装目录,完成后重新启动升级即可解决了。

暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇