WordPress技巧:通过添加代码非插件形式禁用Gutenberg(古腾堡) 编辑器

WordPress 5.0正式版发布以后,新的Gutenberg 编辑器(在WP5.0中准确地说应该叫block editor编辑器)给众多用户带来困惑,很简单的文字编辑操作,变得繁琐复杂,虽然用户对这个编辑器意见很大,但WP开发团队强推也没有办法。

但是我们可以通过安装Classic Editor或者Disable Gutenberg插件,切换回经典的编辑器。

其实之前经典的Classic Editor编辑器代码,在WordPress 5.0并没有被删除,上述插件也只是个切换开关而已。

关键代码就一句:

add_filter('use_block_editor_for_post', '__return_false');

将代码添加到当前主题函数模板functions.php中,即可切换回之前的编辑器,根本不需要那些插件。

当然你想有更多的选择性,可以安装上述插件。

后台禁用block editor编辑器后,前端还是会加载相关的的样式文件,需要加上一句:

remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

禁止前端加载样式文件。

如果你有一个拥有自定义帖子类型(CPT)的网站或者开发一个注册了它们的插件,你就可以阻止Gutenberg用一些东西劫持通常的用户界面。要么确保编辑注册参数以显式设置show_in_rest为false,要么您需要为CPT使用REST API,那么您可以使用以下过滤器为您的CPT关闭Gutenberg:

add_filter( ‘gutenberg_can_edit_post_type’, ‘my_gutenberg_can_edit_post_types’ );
function my_gutenberg_can_edit_post_types( $can_edit, $post_type ) {
    If ( in_array( $post_type, array( ‘a_post_type’, ‘another_post_type’ ) ) {
        return false;
    }

    return $can_edit;
}

Classic Editor编辑器代码据WP官方称会延续集成到2021年才会从程序中彻底删除,但大家也不用担心,到时会有全套的Classic Editor编辑器插件让你选择。

完整中文版估计遥遥无期,目前5.0版完全可以用之前的语言文件,除了新编辑器没有汉化,其它没有影响。

看了一下其它语言的WP程序,目前都没有本地化编辑器。

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注