1、将VPS操作系统换到 Ubuntu 14.04 amd64。因为占用空间小,而BBR只支持64位系统,且要求 glibc 版本 2.14 以上。

2、执行

ldd --version

看看自己的gcc版本,大于等于2.14就可以跳过本步。如果是低于2.14版本的,还需要执行如下指令手动编译安装高版本的:


wget https://ftp.gnu.org/gnu/glibc/glibc-2.15.tar.gz
wget https://ftp.gnu.org/gnu/glibc/glibc-ports-2.15.tar.gz
tar -zxf glibc-2.15.tar.gz
tar -zxf glibc-ports-2.15.tar.gz
mv glibc-ports-2.15 glibc-2.15/ports
mkdir glibc-build-2.15
cd glibc-build-2.15
../glibc-2.15/configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
make all && make install

3、安装BBR

wget https://raw.githubusercontent.com/kuoruan/shell-scripts/master/ovz-bbr/ovz-bbr-installer.sh
chmod +x ovz-bbr-installer.sh
./ovz-bbr-installer.sh

4、如果安装过程顺利,就搞定了。当然,我是不顺利的,我遇到提示tun异常的情况。
是通过执行如下指令后,解决的:

sudo mkdir /dev/net
sudo mknod /dev/net/tun c 10 200
ip tuntap add tap0 mode tap

执行完后,再次执行安装脚本就OK了。其他奇葩问题,尝试未果的可以留言.